Introduction
Cyberduck is a third-party application that allows secure uploading and downloading of files between servers and computers via Secure File Transfer Protocol (SFTP).
The following is an overview of troubleshooting tips and guidance when using Cyberduck for bulk exporting files from FYI.
Issue
An error "Access Denied... Please verify disk permissions" displays when attempting to export documents
Cause
The destination file path is too long and causes the error to display, as Windows has a limit of 256 characters.
Solution
Set only the required categories when configuring the export.
FYI recommends Client Name, Category - Year and Cabinet as a default configuration.
Note: A .csv file containing all metadata is exported as part of the bulk export process. Refer Index .csv File and Additional Metadata in Bulk Export.
Issue
When attempting to perform an export using Cyberduck, the error "Login failed. Exhausted available authentication methods" displays.
Cause
The username specified does not belong to an active FYI account, or the regenerated keys have not been used to perform an export yet.
Earlier keys will not work if a different email address is used to regenerate the keys.
Solution
Ensure that the username added to the connection window is an active FYI account. Refer to Security section in Bulk Export.
Regenerated keys (.pem file) must be used to execute an export so that the keys are created in AWS. If the regenerated keys have not executed an export yet, the connection cannot be established.
Ensure that the regenerated keys have been used to run an export first. Once the export has completed, use the FYI username and regenerated keys (.pem) to view previous exports or export documents.
Issue
A warning "Unknown Fingerprint" displays when connecting via SFTP to export documents from FYI
Cause
The window displays as it is asking to verify the identity of the server that is being accessed
Solution
Tick "Always" from the bottom left corner and then select Allow
Issue
My export is taking a long time.
Cause
Software updates to the FYI platform will restart any export in progress.
Solution
Plan your bulk update around FYI's weekly releases, which occur Thursday evenings.
Issue
An error "Interoperability Failure: Connection blocked because server only allows public key authentication"" displays when attempting to perform a bulk export.
Cause
The network may be blocking SFTP connections, which prevents the connection to AWS from establishing. Or the public host key has changed due to a new export being performed, and the .pem file generated from FYI can no longer be used to authenticate the connection.
Solution
Consider using a different network connection, or have IT review the firewall settings to ensure the connection can be established.
Ensure the correct .pem file is being used in Cyberduck. Otherwise, regenerate the .pem file and perform a new export. Refer to Bulk Export.
If the issue persists, please contact FYI Support.