Issue
We are currently aware of occasional delays in the sync from Xero Practice Manager to FYI.
We are also currently experiencing delays due to Xero's new oAuth. Refer to Occasional Delays in Syncing with Xero Practice Manager due to Xero's new oAuth.
Cause
All automatic sync requests are placed into a queue to process within FYI. Once processed the FYI platform requests the data from Xero Practice Manager and updates your practice data accordingly. When there are large numbers of sync requests, a queue backlog is created which affects our sync time frequencies.
Solution
Minimise the Queue Backlog
To minimize a queue backlog for sync requests, please consider the following:
- Do not request the Sync multiple times. Each time the Sync is requested it sends another request into the queue which decreases system response times.
- Update all Job States in FYI directly.
- If relevant, sync only what is needed at that time (for example, Clients, Jobs, Users or Tax Returns. Refer to Running a Manual Sync with Xero Practice Manager and Additional Notes on Syncing.
Please note that if you are renaming or deleting a Job State in Xero Practice Manager, these are not automatically updated in FYI. For details on how to archive, rename or delete a Job State in FYI, refer to Job States.
While we have limited control over the syncing process with Xero Practice Manager, we are currently developing enhancements to increase visibility and frequency on syncs including:
- Status notifications to show users where sync requests are up to.
- Prioritising different areas of the Xero Practice Manager sync to ensure that time-sensitive updates are actioned over more stagnant changes.
- Increasing the availability to update details in FYI so that changes can be reflected immediately in Xero Practice Manager.
Reconnect to Xero
If data appears to have stopped synchronising altogether, you can disconnect and reconnect to Xero Practice Manager.
Refer to Resetting your connection between FYI and Xero Practice Manager.