Issue
When opening a document in FYI to edit it, the following error displays:
'Sorry, we couldn't find "https://...". Is it possible it was moved, renamed or deleted?
Cause
When opening documents via OneDrive, FYI does not have control of when a document has been sent to OneDrive and cannot check it has been sent.
If your OneDrive is often syncing for reasons outside of the typical FYI functions, this needs to be resolved.
If your OneDrive is often or permanently syncing, this can be caused by a slow internet. It is commonly caused if you are syncing a very large number of documents, or if the documents that are syncing are very large. For example, trying to sync a whole directory across the network is not something that OneDrive is designed to handle.
We recommend that you observe the OneDrive icon to check if it is often syncing or even permanently syncing. If this is the case, you can investigate which files have been added to OneDrive and if they were added by mistake. See below Step 1 - Check if the OneDrive is Permanently or Often Syncing.
Solution
The following steps have reduced the frequency of the issue occurring, however, it will not guarantee the issue will not ever occur. This is because it can also be caused by slow internet or a backlog of files to sync within each user's OneDrive.
If you are syncing a large number of documents, it is likely that these will mostly be historical documents. Users can change the setting in their profile for Preview Office Via OneDrive. This determines how the Preview function displays Office documents. Refer to Previewing a Document and Setting Defaults and AutoFile Defaults for your own Login - My Settings.
Step 1 - Check if the OneDrive is Permanently or Often Syncing
Observe the OneDrive icon on the right-hand side of your windows toolbar. This will show as in the image below to indicate it is not syncing.
If the icon shows as spinning, this indicates it is syncing.
We recommend that you observe the OneDrive icon to check if it is often syncing or even permanently syncing. If this is the case, you can click on the icon to display the files to investigate which have been added to OneDrive and if they were added by mistake.
Step 2 - Make sure your OneDrive is in sync and says "Up to date"
If you are syncing a large number of documents to your OneDrive, for example, if you are syncing documents separate from those from FYI, this will be a contributing factor to the error.
You can hover over the OneDrive icon on the right-hand side of the windows toolbar and check this says "Up to date".
If OneDrive is often syncing other files and not able to keep up, our strong recommendation is to stop syncing any other folder locations as follows:
- Open the OneDrive app on your desktop computer.
- From the OneDrive options menu, click Account.
- For any other folder locations being synced containing a large number of files, select "Stop sync".
Note: If OneDrive is having sync issues with documents being queued, this will affect the editing of Office documents on the desktop from FYI. If the above steps have not solved the issue, then please contact your IT consultant to investigate further and rectify.
Step 3 - Check your OneDrive settings
- Open the OneDrive app on your desktop computer.
- Click Help & Settings.
- Select Settings.
- Go to the Office tab.
- Ensure that the option "Use Office to sync Office files that I open" is checked.
- Click OK to save the setting.
Step 4 - Set FYI - My Edits to Keep all files locally
- Open Windows Explorer.
- In the navigation pane expand your OneDrive.
- Right-click the folder FYI - My Edits.
- Select Always keep on this Device.
For more information, refer to the Microsoft forum article https://answers.microsoft.com/en-us/msoffice/forum/msoffice_excel-mso_mac-mso_365hp/since-last-update-files-saving-to-onedrive-cloud/8cc8d398-ad53-4746-b258-dde91a87ba1e?messageId=9ff47f6d-330d-48a2-aa88-6f292c521985&tm=1598030791275
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