This article covers the following:
- Authentication error when installing the FYI Migrate app
- Error "Authentication error: Authentication failed: An error response was returned by the OAuth2 server, but it could not be parsed. Please inspect the exception properties for details" in the FYI Migration app
- Error "Exception retrieving Invu data" when starting the FYI Migration app
- No permissions in ACL
- Error due to a file system limitation and the sync stops at a certain file
- Error occurred connecting to database
Authentication error when installing the FYI Migrate app
When installing the FYI Migrate app the following error displays:
"Authentication error: Authentication failed Uri mismatch. Expected (/favcon.ico) Actual (/)."
Cause
This is related to the browser that you have as your default browser. For example, if the computer you are running the FYI Migrate on only has Internet Explorer installed and this is set as the default browser. This is not compatible with the FYI Migration app.
Solution
Install Chrome and make this your default browser.
Error "Authentication error: Authentication failed: An error response was returned by the OAuth2 server, but it could not be parsed. Please inspect the exception properties for details" in the FYI Migration app
When installing and starting the FYI Migrate app we get the following error.
Cause
If you have a proxy or firewall on the computer you are using to install the FYI Migrate App, either of these could be interfering with FYI Migrate App being able to make a successful connection.
Solution
When the Welcome to FYI Migrate screen displays, checkmark Use HTTP Proxy and enter the details for Host, Port, username and Password. If you do not know the details to enter, you will need to contact your IT consultant.
If this does not stop the error, you will need to consult your IT consultant who may need to configure the proxy settings to allow access through the firewall.
Error "Exception retrieving Invu data" when starting the FYI Migration app
When starting the FYI Migration app, if you get an error such as "Exception retrieving Invu data" and the app skips all documents, this is due to an out-of-date FYI Migration app.
If you have been given the link to download the FYI Migrate app, download this again to make sure you have the latest version and start the migration process again.
If you are still seeing the error, please contact your Client Success Manager to download the latest FYI Migrate app.
No permissions in ACL
After selecting the folders to migrate, a permission error displays.
Error: Permission error for folder "foldername"
Ensure the path exists and you have read permissions.
Error: No permissions in ACL
Cause
You do not have sufficient permissions to enable the FYI Migrate application to access and upload your documents.
Solution
- Run the Migrate App as Administrator
- If the application is open, close the application
- Right click on the application file, and select 'Run as administrator'
- Request IT assistance to upgrade your permissions
- If running as Administrator does not work, or you do not have access to run as administrator, please forward this guide to your IT provider.
Error due to a file system limitation and the sync stops at a certain file
If the syncing is giving a file system limitation error and the sync is stopping, this is likely due to fragmentation in a large file. This situation should not occur as the migration app will check for fragmentation and copy the file if needed. If the migration app is running for a long time however, this could still occur, but restarting the migration app should fix this by copying the file.
If needed, the following are instructions for how to correct this manually.
For example, in the following error, the fragmentation was in the fyi_data file.
"The requested operation could not be completed due to a file system limitation : 'C:\Users\aaaaaa\AppData\Roaming\FYI Migrate\fyi_data.db'
To correct this:
- Shut down the migration app.
- Locate the file as shown in the error that was displayed.
- Take a copy of the file to another location.
- Delete the original file.
- Move the copied file back to where the original was with the same name.
- Restart the app.
Error occurred connecting to database
When trying to start Migrate App a message is displayed:
"Error occurred connecting to database ...:"
- Check the database again to confirm that the correct one is being selected. Sometimes there are two that look similar, but only one of them is the actual document management.
- Check the connections details and try with SQL Server Management Studio to confirm they are correct. Refer to How to find MYOB and Virtual Cabinet Server and Database Details in Document Migration for MYOB or Virtual Cabinet.
- Check if the database server local or remote.
- Check that you have already logged into the FYI app as the user you are using to run the FYIMigrate app.