FYI is slow or does not load documents when working from the Philippines

Issue
I am working from the Philippines and when trying to use FYI it is very slow, times out, or does not load documents. Other applications and websites seem to be working correctly.

Cause
For users in the Philippines, this appears to be an issue with the internet provider Philippine Long Distance Telephone Company (PLDT) blocking the connection with FYI.

Solution
Change to a different internet provider. You can tether to a smartphone or personal hotspot, or use another internet connection if available

FYI is monitoring the issue and will update this page with any new information.

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