Issue
For practices integrated with Xero Practice Manager, when updating a job in FYI, the following message displays in Practice Activity:
"Error updating job state - Change to state not accepted by XPM"
Cause
The Job State for the Job has been changed in Xero Practice Manager but this has not yet synced to FYI. The change is therefore rejected in Xero Practice Manager as the two are out of sync.
Solution
- Consider setting Maintain Jobs In FYI for your practice so that changes to Jobs are only made in FYI. Refer to Option to Maintain Jobs in FYI in Running a Manual Sync with Xero Practice Manager and Additional Notes on Syncing.
- Perform a manual Job sync from Xero Practice Manager before updating the Job in FYI. Refer to Manual Sync in Synchronising Clients, Staff, Jobs, Time, Tax Returns with Xero Practice Manager.